# CVE-2026-86083: n8n: Expression Sandbox Escape via Shared Builtin Tampering and Code-Printer Injection Leads to Code Execution

> Attackers can execute arbitrary code in n8n by tampering with builtins to inject malicious code into generated expressions.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-6xcw-7xm6-48c6, MINI-vf72-m2jm-7fm4, ROOT-APP-NPM-CVE-2026-86083

## What is CVE-2026-86083?

CVE-2026-86083 is a high-severity code injection vulnerability in N8n N8n, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to 1.123.76, 2.37.7, and 2.38.2, the legacy expression engine generated source text by calling the mutable global JSON.stringify while printing synthetic string literals and interpolating timezone data. An expression could replace JSON.stringify and cause later generated source to contain executable attacker-controlled code. The affected code-generation paths include packages/@n8n/expression-runtime/src/bridge/isolated-vm-bridge.ts and packages/@n8n/tournament/src/ExpressionBuilder.ts, and the issue does not affect the vm expression engine. This issue is fixed in versions 1.123.76, 2.37.7 and 2.38.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-86083?

6 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.76 |
| `n8n` | npm | All versions | 1.123.76 |
| `n8n` | npm | From 2.0.0 | 2.37.7 |
| `n8n` | npm | From 2.0.0 | 2.37.7 |
| `n8n` | npm | From 2.38.0 | 2.38.2 |
| `n8n` | npm | From 2.38.0 | 2.38.2 |

Products: N8n N8n.

## How do I fix CVE-2026-86083?

Upgrade n8n to a fixed version for your release line: 1.123.76, 2.37.7 or 2.38.2.

## Is CVE-2026-86083 being exploited?

There is no known exploitation of CVE-2026-86083 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86083 and fix it if it is affected.

What it is: CVE-2026-86083 is a high-severity code injection vulnerability in N8n N8n, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86083 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.76
- n8n (npm): affected all versions; fixed in 1.123.76
- n8n (npm): affected from 2.0.0; fixed in 2.37.7
- n8n (npm): affected from 2.0.0; fixed in 2.37.7
- n8n (npm): affected from 2.38.0; fixed in 2.38.2
- n8n (npm): affected from 2.38.0; fixed in 2.38.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86083/ (Markdown: https://insights.sbomify.com/CVE-2026-86083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86083
- OSV: https://osv.dev/vulnerability/CVE-2026-86083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86083/
Summaries are generated and may contain mistakes; the official description above is the record.
