CVE-2026-86084 n8n: Disabled OIDC SSO Endpoints Remain Active and Issue Valid Sessions
Attackers can bypass authentication and gain valid sessions via disabled OIDC endpoints in n8n, requiring an upgrade to secure the platform.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86084?
CVE-2026-86084 is a medium-severity authentication bypass vulnerability in N8n N8n, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.76, 2.37.7, and 2.38.2, the public OIDC login and callback endpoints completed authentication even when OIDC was not the enabled active authentication method. An Enterprise administrator who had configured and later disabled an identity provider still exposed a working route that could issue valid sessions. The affected logic is packages/cli/src/modules/sso-oidc/oidc.service.ee.ts, including generateLoginUrl and the callback flow that lacked assertOidcLoginEnabled. This issue is fixed in versions 1.123.76, 2.37.7 and 2.38.2.
Weakness: CWE-288
Which versions are affected by CVE-2026-86084?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.76 |
n8n npm | All versions | 1.123.76 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.0.0 | 2.37.7 |
n8n npm | From 2.38.0 | 2.38.2 |
n8n npm | From 2.38.0 | 2.38.2 |
Products include N8n N8n.
How do I fix CVE-2026-86084?
Upgrade n8n to a fixed version for your release line: 1.123.76, 2.37.7 or 2.38.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-86084 being exploited?
There is no known exploitation of CVE-2026-86084 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-pf83-w3f9-8m37, MINI-xhh2-37qr-6hjr.