# CVE-2026-86089: Apache NiFi: Missing Process Group Authorization for Connector Migration

> Authenticated users can bypass Process Group authorization to enumerate or migrate flows without proper access rights in Apache NiFi.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/S:P/AU:Y/R:U/V:C/RE:L/U:Clear`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** BIT-nifi-2026-86089, GHSA-5rjq-rw3w-qr4c, MINI-r6f5-p3m4-62vm

## What is CVE-2026-86089?

CVE-2026-86089 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache NiFi 2.11.0 supports migrating the contents of a version-controlled Process Group into a Connector using REST API methods that list eligible migration sources and submit migration requests. The framework authorized both methods against the target Connector alone, without evaluating access to the Process Groups involved. The absence of Process Group authorization allowed an authenticated user with read access to a Connector to enumerate the identifiers, names, and flow registry details of version-controlled Process Groups outside the scope of granted read policies. It also allowed a user with write access to a Connector to migrate a Process Group without write access to that Process Group, copying the flow definition, referenced assets, and component state into the Connector, and leaving the source Process Group disabled and renamed. Migration excludes sensitive property values and requires the source Process Group to be stopped with empty queues, which limits the scope of exposure. Apache NiFi installations that do not implement component-level authorization policies for Process Groups are not subject to this vulnerability, because the framework enforces Connector write permissions as the security boundary. Upgrading to Apache NiFi 2.12.0 is the recommended mitigation, which filters migration sources to Process Groups the requesting user is authorized to read, and requires write access to the source Process Group when submitting a migration request.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-86089?

1 open source package ship an affected version, including nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nifi` | Bitnami | From 2.11.0 | 2.12.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-86089?

Upgrade nifi to 2.12.0 or later.

## Is CVE-2026-86089 being exploited?

There is no known exploitation of CVE-2026-86089 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86089 and fix it if it is affected.

What it is: CVE-2026-86089 is a low-severity missing authorization vulnerability in Apache Nifi, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86089 in the wild and no public exploit code.

Affected packages and fixed versions:
- nifi (Bitnami): affected from 2.11.0; fixed in 2.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86089/ (Markdown: https://insights.sbomify.com/CVE-2026-86089/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86089
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86089
- OSV: https://osv.dev/vulnerability/CVE-2026-86089

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86089/
Summaries are generated and may contain mistakes; the official description above is the record.
