{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav.","exploited":"There is no known exploitation of CVE-2026-86197 in the wild and no public exploit code.","fix":"Upgrade getgrav/grav to 2.0.20 or later.","what":"CVE-2026-86197 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 5 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-86197 and fix it if it is affected.\n\nWhat it is: CVE-2026-86197 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 5 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-86197 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.20\n- getgrav/grav (Packagist): affected all versions; fixed in 2.0.20\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86197/ (Markdown: https://insights.sbomify.com/CVE-2026-86197/index.md)","id":"CVE-2026-86197","markdown":"https://insights.sbomify.com/CVE-2026-86197/index.md","name":"CVE-2026-86197","record":{"aliases":["GHSA-5pmv-xr2f-mrf8","GHSA-8hgv-xc77-jmcr"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"low_privilege","summary":"Page editors can inject malicious scripts via asset methods, leading to code execution and potential account takeover for all visitors including administrators.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Grav before 2.0.20 contains a cross-site scripting vulnerability in the Twig sandbox policy that allowlists addJs and addCss methods on Grav\\Common\\Assets without proper output escaping. Page editors can inject arbitrary script by registering malicious assets or injecting attributes, which are rendered unescaped into document head tags and executed for all visitors including administrators.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Grav before 2.0.20 Cross-Site Scripting via Assets Sandbox","id":"CVE-2026-86197","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"PocketMine-MP before 5.44.2 Denial of Service via ResourcePackClientResponsePacket","id":"CVE-2026-86198"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.20"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-8hgv-xc77-jmcr"},{"ecosystem":"Packagist","fixed":["2.0.20"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-8hgv-xc77-jmcr"}],"prev":{"headline":"Grav API Plugin before 1.0.20 Authentication Bypass via Host Header","id":"CVE-2026-86196"},"products":["grav"],"published":"2026-09-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["getgrav"]},"summary":"Page editors can inject malicious scripts via asset methods, leading to code execution and potential account takeover for all visitors including administrators.","url":"https://insights.sbomify.com/CVE-2026-86197/"}