# CVE-2026-86200: PocketMine-MP before 5.42.1 LogDoS via LoginPacket clientData JWT

> Remote attackers can cause denial of service in PocketMine-MP by flooding server logs with junk data via malicious login packets.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h5mw-4vcp-gq3w, GHSA-xp4f-g2cm-rhg7

## What is CVE-2026-86200?

CVE-2026-86200 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PocketMine-MP versions before 5.42.1 contain a denial of service vulnerability in the LoginPacket handler that allows remote attackers to flood warning messages by injecting numerous junk properties into the clientData JWT. Attackers can craft malicious login packets with excessive unknown properties to waste server CPU time and degrade performance.

Weakness: CWE-779 (Logging of Excessive Data)

## Which versions are affected by CVE-2026-86200?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.42.1 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.42.1 |

## How do I fix CVE-2026-86200?

Upgrade pocketmine/pocketmine-mp to 5.42.1 or later.

## Is CVE-2026-86200 being exploited?

There is no known exploitation of CVE-2026-86200 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86200 and fix it if it is affected.

What it is: CVE-2026-86200 is a medium-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86200 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.42.1
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.42.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86200/ (Markdown: https://insights.sbomify.com/CVE-2026-86200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86200
- OSV: https://osv.dev/vulnerability/CVE-2026-86200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86200/
Summaries are generated and may contain mistakes; the official description above is the record.
