# CVE-2026-86203: PocketMine-MP before 5.39.2 Item Duplication via Despawn State

> Attackers can duplicate items and experience by exploiting a race condition in entity despawn handling, affecting PocketMine-MP server administrators.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-9pw9-9mpc-9mc3, GHSA-f9jp-856v-8642

## What is CVE-2026-86203?

CVE-2026-86203 is a medium-severity vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PocketMine-MP versions before 5.39.2 fail to validate entity despawn state when processing attack packets from clients. Attackers can exploit a race condition by attacking a disconnecting player to trigger multiple death handlers, causing inventory items and experience to drop multiple times for duplication.

Weakness: CWE-664 (Improper Control of a Resource Through its Lifetime)

## Which versions are affected by CVE-2026-86203?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.39.2 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.39.2 |

## How do I fix CVE-2026-86203?

Upgrade pocketmine/pocketmine-mp to 5.39.2 or later.

## Is CVE-2026-86203 being exploited?

There is no known exploitation of CVE-2026-86203 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86203 and fix it if it is affected.

What it is: CVE-2026-86203 is a medium-severity vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86203 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86203/ (Markdown: https://insights.sbomify.com/CVE-2026-86203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86203
- OSV: https://osv.dev/vulnerability/CVE-2026-86203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86203/
Summaries are generated and may contain mistakes; the official description above is the record.
