{"answers":{"affected":"2 open source packages ship an affected version, including pocketmine/pocketmine-mp.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86204 exists.","fix":"Upgrade pocketmine/pocketmine-mp to 5.39.2 or later.","what":"CVE-2026-86204 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-86204 and fix it if it is affected.\n\nWhat it is: CVE-2026-86204 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86204 exists.\n\nAffected packages and fixed versions:\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2\n- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86204/ (Markdown: https://insights.sbomify.com/CVE-2026-86204/index.md)","id":"CVE-2026-86204","markdown":"https://insights.sbomify.com/CVE-2026-86204/index.md","name":"CVE-2026-86204","record":{"aliases":["GHSA-323m-6rhr-p53j","GHSA-788v-5pfp-93ff"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Minecraft server software","requires_auth":"low_privilege","summary":"Authenticated players can crash PocketMine-MP servers by sending oversized JSON payloads in modal form responses, exhausting resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"PocketMine-MP versions before 5.39.2 fail to limit JSON payload size in ModalFormResponsePacket handling, allowing authenticated players to cause denial of service. Attackers can send modal form response packets with massive JSON arrays to exhaust server memory and CPU resources, rendering the server unresponsive.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket","id":"CVE-2026-86204","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"h3 before 2.0.1-rc.18 Open Redirect via redirectBack()","id":"CVE-2026-86205"},"packages":[{"ecosystem":"Packagist","fixed":["5.39.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":null,"source":"GHSA-788v-5pfp-93ff"},{"ecosystem":"Packagist","fixed":["5.39.2"],"introduced":["0"],"last_affected":[],"package":"pocketmine/pocketmine-mp","purl":"pkg:composer/pocketmine/pocketmine-mp","source":"GHSA-788v-5pfp-93ff"}],"prev":{"headline":"PocketMine-MP before 5.39.2 Item Duplication via Despawn State","id":"CVE-2026-86203"},"products":["PocketMine-MP"],"published":"2026-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["pmmp"]},"summary":"Authenticated players can crash PocketMine-MP servers by sending oversized JSON payloads in modal form responses, exhausting resources.","url":"https://insights.sbomify.com/CVE-2026-86204/"}