# CVE-2026-86204: PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket

> Authenticated players can crash PocketMine-MP servers by sending oversized JSON payloads in modal form responses, exhausting resources.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-323m-6rhr-p53j, GHSA-788v-5pfp-93ff

## What is CVE-2026-86204?

CVE-2026-86204 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions before 5.39.2 fail to limit JSON payload size in ModalFormResponsePacket handling, allowing authenticated players to cause denial of service. Attackers can send modal form response packets with massive JSON arrays to exhaust server memory and CPU resources, rendering the server unresponsive.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-86204?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.39.2 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.39.2 |

## How do I fix CVE-2026-86204?

Upgrade pocketmine/pocketmine-mp to 5.39.2 or later.

## Is CVE-2026-86204 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86204 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86204 and fix it if it is affected.

What it is: CVE-2026-86204 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86204 exists.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.39.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86204/ (Markdown: https://insights.sbomify.com/CVE-2026-86204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86204
- OSV: https://osv.dev/vulnerability/CVE-2026-86204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86204/
Summaries are generated and may contain mistakes; the official description above is the record.
