{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-86243 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-86243 is a high-severity denial of service vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-86243 and fix it if it is affected.\n\nWhat it is: CVE-2026-86243 is a high-severity denial of service vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-86243 in the wild and no public exploit code.\n\nAffected product: Apache Tomcat Native. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86243/ (Markdown: https://insights.sbomify.com/CVE-2026-86243/index.md)","id":"CVE-2026-86243","markdown":"https://insights.sbomify.com/CVE-2026-86243/index.md","name":"CVE-2026-86243","record":{"aliases":["DEBIAN-CVE-2026-86243","GHSA-w68h-fc49-cmrg","MINI-24w8-4395-c3ch","UBUNTU-CVE-2026-86243"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Tomcat Native","requires_auth":"none","summary":"A buffer over-read in Apache Tomcat Native during TLS handshake allows attackers to cause a JVM crash and denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"tomcat_native","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-126","name":"Buffer Over-read"}],"description":"Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash.\n\nThis issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected.\n\nUsers are recommended to upgrade to version 1.3.9 or 2.0.16, which fix the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tomcat Native: DoS via TLS handshake","id":"CVE-2026-86243","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"FastAdmin User Controller User.php login cross site scripting","id":"CVE-2026-86244"},"packages":[],"prev":{"headline":"Unauthenticated RCE via Custom Plugin HTTP Path on Dynamically Linked Builds","id":"CVE-2026-86242"},"products":["Apache Tomcat Native"],"published":"2026-09-23","related":[{"cvss_score":9.1,"headline":"Apache Tomcat Native: Insecure OpenSSL options enabled","id":"CVE-2026-86246","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":7.4,"headline":"Apache Tomcat Native: Client certificate requirements can be down-graded","id":"CVE-2026-86247","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":7.4,"headline":"Auth bypass in Apache Tomcat Native","id":"CVE-2018-8019","kev_date_added":null,"published":"2018-07-31"},{"cvss_score":7.4,"headline":"Auth bypass in Apache Tomcat Native","id":"CVE-2018-8020","kev_date_added":null,"published":"2018-07-31"},{"cvss_score":5.9,"headline":"Security feature bypass in Apache Tomcat Native","id":"CVE-2017-15698","kev_date_added":null,"published":"2018-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["Apache Software Foundation"]},"summary":"A buffer over-read in Apache Tomcat Native during TLS handshake allows attackers to cause a JVM crash and denial of service.","url":"https://insights.sbomify.com/CVE-2026-86243/"}