CVE-2026-86247 Apache Tomcat Native: Client certificate requirements can be down-graded
A race condition in Apache Tomcat Native allows attackers to downgrade client certificate verification requirements in specific configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86247?
CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.
This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected.
Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.
Weakness: CWE-366
Which versions are affected by CVE-2026-86247?
It affects 1 product.
Products include Apache Tomcat Native.
How do I fix CVE-2026-86247?
Upgrade to a fixed version.
Is CVE-2026-86247 being exploited?
There is no known exploitation of CVE-2026-86247 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat Native
Sources
Also known as DEBIAN-CVE-2026-86247, GHSA-jhrw-x5gg-jjqw, MINI-rc2v-69jh-jj3g, UBUNTU-CVE-2026-86247.