{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-86247 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-86247 and fix it if it is affected.\n\nWhat it is: CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-86247 in the wild and no public exploit code.\n\nAffected product: Apache Tomcat Native. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86247/ (Markdown: https://insights.sbomify.com/CVE-2026-86247/index.md)","id":"CVE-2026-86247","markdown":"https://insights.sbomify.com/CVE-2026-86247/index.md","name":"CVE-2026-86247","record":{"aliases":["DEBIAN-CVE-2026-86247","GHSA-jhrw-x5gg-jjqw","MINI-rc2v-69jh-jj3g","UBUNTU-CVE-2026-86247"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Tomcat Native","requires_auth":"none","summary":"A race condition in Apache Tomcat Native allows attackers to downgrade client certificate verification requirements in specific configurations.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"tomcat_native","vendor":"apache"}],"cvss":{"score":7.4,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-366","name":"Race Condition within a Thread"}],"description":"Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.\n\nThis issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected.\n\nUsers are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tomcat Native: Client certificate requirements can be down-graded","id":"CVE-2026-86247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Auth bypass in Apache Tomcat","id":"CVE-2026-86248"},"packages":[],"prev":{"headline":"Apache Tomcat Native: Insecure OpenSSL options enabled","id":"CVE-2026-86246"},"products":["Apache Tomcat Native"],"published":"2026-09-23","related":[{"cvss_score":9.1,"headline":"Apache Tomcat Native: Insecure OpenSSL options enabled","id":"CVE-2026-86246","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":7.5,"headline":"Apache Tomcat Native: DoS via TLS handshake","id":"CVE-2026-86243","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":7.4,"headline":"Auth bypass in Apache Tomcat Native","id":"CVE-2018-8019","kev_date_added":null,"published":"2018-07-31"},{"cvss_score":7.4,"headline":"Auth bypass in Apache Tomcat Native","id":"CVE-2018-8020","kev_date_added":null,"published":"2018-07-31"},{"cvss_score":5.9,"headline":"Security feature bypass in Apache Tomcat Native","id":"CVE-2017-15698","kev_date_added":null,"published":"2018-01-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["Apache Software Foundation"]},"summary":"A race condition in Apache Tomcat Native allows attackers to downgrade client certificate verification requirements in specific configurations.","url":"https://insights.sbomify.com/CVE-2026-86247/"}