# CVE-2026-86247: Apache Tomcat Native: Client certificate requirements can be down-graded

> A race condition in Apache Tomcat Native allows attackers to downgrade client certificate verification requirements in specific configurations.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-86247, GHSA-jhrw-x5gg-jjqw, MINI-rc2v-69jh-jj3g, UBUNTU-CVE-2026-86247

## What is CVE-2026-86247?

CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations.

This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected.

Users are recommended to upgrade to version 2.0.16 or 1.3.9, which fixes the issue.

Weakness: CWE-366 (Race Condition within a Thread)

## Which versions are affected by CVE-2026-86247?

It affects 1 product.


Products: Apache Tomcat Native.

## How do I fix CVE-2026-86247?

Upgrade to a fixed version.

## Is CVE-2026-86247 being exploited?

There is no known exploitation of CVE-2026-86247 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tomcat Native

- [CVE-2026-86246](https://insights.sbomify.com/CVE-2026-86246/): Apache Tomcat Native: Insecure OpenSSL options enabled (critical 9.1)
- [CVE-2026-86243](https://insights.sbomify.com/CVE-2026-86243/): Apache Tomcat Native: DoS via TLS handshake (high 7.5)
- [CVE-2018-8019](https://insights.sbomify.com/CVE-2018-8019/): Auth bypass in Apache Tomcat Native (high 7.4)
- [CVE-2018-8020](https://insights.sbomify.com/CVE-2018-8020/): Auth bypass in Apache Tomcat Native (high 7.4)
- [CVE-2017-15698](https://insights.sbomify.com/CVE-2017-15698/): Security feature bypass in Apache Tomcat Native (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86247 and fix it if it is affected.

What it is: CVE-2026-86247 is a high-severity vulnerability in Apache Tomcat Native, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86247 in the wild and no public exploit code.

Affected product: Apache Tomcat Native. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86247/ (Markdown: https://insights.sbomify.com/CVE-2026-86247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86247
- OSV: https://osv.dev/vulnerability/CVE-2026-86247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86247/
Summaries are generated and may contain mistakes; the official description above is the record.
