CVE-2026-86248 Auth bypass in Apache Tomcat
Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86248?
CVE-2026-86248 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from 10.1.22 through 10.1.59, from 9.0.92 through 9.0.121.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.
Weakness: CWE-287
Which versions are affected by CVE-2026-86248?
1 open source package ship an affected version, including tomcat.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | From 9.0.92 | 9.0.122, 10.1.60, 11.0.26 |
How do I fix CVE-2026-86248?
Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-86248 being exploited?
There is no known exploitation of CVE-2026-86248 in the wild and no public exploit code.
Sources
Also known as BIT-tomcat-2026-86248, DEBIAN-CVE-2026-86248, GHSA-c47j-g3rg-hrfq, MINI-3xg2-g38c-5mvv, MINI-6c5v-w833-g3gq, MINI-hxvq-xvgc-c9x8 and 1 more.