{"answers":{"affected":"1 open source package ship an affected version, including tomcat.","exploited":"There is no known exploitation of CVE-2026-86248 in the wild and no public exploit code.","fix":"Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.","what":"CVE-2026-86248 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-86248 and fix it if it is affected.\n\nWhat it is: CVE-2026-86248 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-86248 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tomcat (Bitnami): affected from 9.0.92; fixed in 9.0.122, 10.1.60, 11.0.26\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86248/ (Markdown: https://insights.sbomify.com/CVE-2026-86248/index.md)","id":"CVE-2026-86248","markdown":"https://insights.sbomify.com/CVE-2026-86248/index.md","name":"CVE-2026-86248","record":{"aliases":["BIT-tomcat-2026-86248","DEBIAN-CVE-2026-86248","GHSA-c47j-g3rg-hrfq","MINI-3xg2-g38c-5mvv","MINI-6c5v-w833-g3gq","MINI-hxvq-xvgc-c9x8","UBUNTU-CVE-2026-86248"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Tomcat","requires_auth":"none","summary":"Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat.\n\nThis issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from 10.1.22 through 10.1.59, from 9.0.92 through 9.0.121.\n\nUsers are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth bypass in Apache Tomcat","id":"CVE-2026-86248","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Apache bRPC: Authentication bypass when a server sets ServerOptions.internal_port and ServerOptions.auth","id":"CVE-2026-86249"},"packages":[{"ecosystem":"Bitnami","fixed":["9.0.122","10.1.60","11.0.26"],"introduced":["9.0.92","10.1.22","11.0.0"],"last_affected":[],"package":"tomcat","purl":"pkg:bitnami/tomcat","source":"BIT-tomcat-2026-86248"}],"prev":{"headline":"Apache Tomcat Native: Client certificate requirements can be down-graded","id":"CVE-2026-86247"},"products":["Apache Tomcat"],"published":"2026-09-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["Apache Software Foundation"]},"summary":"Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2026-86248/"}