# CVE-2026-86248: Auth bypass in Apache Tomcat

> Attackers can bypass client certificate authentication in Apache Tomcat when OCSP soft-fail is disabled, allowing unauthorized access.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2026
- **Updated:** 23 Sep 2026
- **Also known as:** BIT-tomcat-2026-86248, DEBIAN-CVE-2026-86248, GHSA-c47j-g3rg-hrfq, MINI-3xg2-g38c-5mvv, MINI-6c5v-w833-g3gq, MINI-hxvq-xvgc-c9x8, UBUNTU-CVE-2026-86248

## What is CVE-2026-86248?

CVE-2026-86248 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.25, from 10.1.22 through 10.1.59, from 9.0.92 through 9.0.121.

Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-86248?

1 open source package ship an affected version, including tomcat.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | From 9.0.92 | 9.0.122, 10.1.60, 11.0.26 |

## How do I fix CVE-2026-86248?

Upgrade tomcat to a fixed version for your release line: 9.0.122, 10.1.60 or 11.0.26.

## Is CVE-2026-86248 being exploited?

There is no known exploitation of CVE-2026-86248 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86248 and fix it if it is affected.

What it is: CVE-2026-86248 is a critical authentication bypass vulnerability in Apache Tomcat, published on 23 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86248 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected from 9.0.92; fixed in 9.0.122, 10.1.60, 11.0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86248/ (Markdown: https://insights.sbomify.com/CVE-2026-86248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86248
- OSV: https://osv.dev/vulnerability/CVE-2026-86248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86248/
Summaries are generated and may contain mistakes; the official description above is the record.
