# CVE-2026-86250: h3 before 2.0.1-rc.18 Denial of Service via Unbounded Chunked Cookie

> Attackers can cause a denial of service by sending crafted cookies with large chunk counts, hanging the server process in the h3 library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2026
- **Updated:** 18 Sep 2026
- **Also known as:** GHSA-q5pr-72pq-83v3

## What is CVE-2026-86250?

CVE-2026-86250 is a high-severity denial of service vulnerability in h3js h3, published on 6 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

h3 versions before 2.0.1-rc.18 fail to validate the chunk count parsed from user-controlled cookie values in setChunkedCookie() and deleteChunkedCookie() functions. Attackers can send a crafted cookie header with an extremely large chunk count to trigger an O(n²) cleanup loop that hangs the server process.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-86250?

2 open source packages ship an affected version, including h3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `h3` | npm | From 2.0.0-beta.4 | 2.0.1-rc.18 |
| `h3` | npm | From 2.0.0-beta.4 | 2.0.1-rc.18 |

## How do I fix CVE-2026-86250?

Upgrade h3 to 2.0.1-rc.18 or later.

## Is CVE-2026-86250 being exploited?

There is no known exploitation of CVE-2026-86250 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86250 and fix it if it is affected.

What it is: CVE-2026-86250 is a high-severity denial of service vulnerability in h3js h3, published on 6 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86250 in the wild and no public exploit code.

Affected packages and fixed versions:
- h3 (npm): affected from 2.0.0-beta.4; fixed in 2.0.1-rc.18
- h3 (npm): affected from 2.0.0-beta.4; fixed in 2.0.1-rc.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86250/ (Markdown: https://insights.sbomify.com/CVE-2026-86250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86250
- OSV: https://osv.dev/vulnerability/CVE-2026-86250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86250/
Summaries are generated and may contain mistakes; the official description above is the record.
