# CVE-2026-86256: wger before 2.6 Open Redirect via trainer-login next parameter

> An attacker can redirect authenticated trainers to malicious sites via a crafted link, enabling phishing and leaking user data.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-rc6j-63fm-mhq4, GHSA-vqv8-j3mj-wjxj

## What is CVE-2026-86256?

CVE-2026-86256 is a medium-severity vulnerability in wger-project wger, published on 6 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

wger before 2.6 (affected versions <= 2.5.0) contains an open redirect vulnerability in the trainer_login view (wger/core/views/user.py). After a trainer enters impersonation mode, the view redirects to the user-supplied 'next' GET parameter via HttpResponseRedirect() without validating it with url_has_allowed_host_and_scheme(). An attacker who delivers a crafted link to an authenticated trainer can redirect the trainer's browser to an attacker-controlled domain, enabling phishing and leaking the wger URL structure (including the impersonated user's user_pk) via the Referer header.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-86256?

2 open source packages ship an affected version, including wger.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wger` | PyPI | All versions | 2.6 |
| `wger` | PyPI | All versions | 2.6 |

## How do I fix CVE-2026-86256?

Upgrade wger to 2.6 or later.

## Is CVE-2026-86256 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86256 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86256 and fix it if it is affected.

What it is: CVE-2026-86256 is a medium-severity vulnerability in wger-project wger, published on 6 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86256 exists.

Affected packages and fixed versions:
- wger (PyPI): affected all versions; fixed in 2.6
- wger (PyPI): affected all versions; fixed in 2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86256/ (Markdown: https://insights.sbomify.com/CVE-2026-86256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86256
- OSV: https://osv.dev/vulnerability/CVE-2026-86256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86256/
Summaries are generated and may contain mistakes; the official description above is the record.
