# CVE-2026-86257: wger before 2.6 CSV Formula Injection via member export

> Attackers can inject malicious spreadsheet formulas into exported gym member data, leading to code execution or data exfiltration when admins open the file.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Sep 2026
- **Updated:** 8 Sep 2026
- **Also known as:** GHSA-pmr9-wpc3-f495, GHSA-xq9m-hmp9-fw87

## What is CVE-2026-86257?

CVE-2026-86257 is a medium-severity vulnerability in wger-project wger, published on 6 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

wger before 2.6 fails to sanitize first_name and last_name fields in the gym member TSV export endpoint, allowing any gym member to inject spreadsheet formulas. Attackers can inject formulas like =HYPERLINK to exfiltrate admin data or execute code when admins open the exported file in Excel or LibreOffice Calc.

Weakness: CWE-1236 (Improper Neutralization of Formula Elements in a CSV File)

## Which versions are affected by CVE-2026-86257?

2 open source packages ship an affected version, including wger.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wger` | PyPI | All versions | 2.6 |
| `wger` | PyPI | All versions | 2.6 |

## How do I fix CVE-2026-86257?

Upgrade wger to 2.6 or later.

## Is CVE-2026-86257 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86257 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86257 and fix it if it is affected.

What it is: CVE-2026-86257 is a medium-severity vulnerability in wger-project wger, published on 6 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86257 exists.

Affected packages and fixed versions:
- wger (PyPI): affected all versions; fixed in 2.6
- wger (PyPI): affected all versions; fixed in 2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86257/ (Markdown: https://insights.sbomify.com/CVE-2026-86257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86257
- OSV: https://osv.dev/vulnerability/CVE-2026-86257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86257/
Summaries are generated and may contain mistakes; the official description above is the record.
