CVE-2026-86289 Ollama GGUF Decoder gguf.go readGGUFV1String integer overflow

Medium 5.3 Published Updated

Remote attackers can trigger an integer overflow in the GGUF decoder, potentially causing denial of service or code execution in Ollama.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-86289?

CVE-2026-86289 is a medium-severity vulnerability in Ollama, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.

Weakness: CWE-190, CWE-189

Which versions are affected by CVE-2026-86289?

How do I fix CVE-2026-86289?

No fix has been published for CVE-2026-86289 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-86289 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86289 exists.

Sources

Also known as GHSA-c2q9-58w2-gjg4.

Is CVE-2026-86289 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free