{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86289 exists.","fix":"No fix has been published for CVE-2026-86289 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-86289 is a medium-severity vulnerability in Ollama, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-86289 and fix it if it is affected.\n\nWhat it is: CVE-2026-86289 is a medium-severity vulnerability in Ollama, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-86289 exists.\n\nAffected product: Ollama. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86289/ (Markdown: https://insights.sbomify.com/CVE-2026-86289/index.md)","id":"CVE-2026-86289","markdown":"https://insights.sbomify.com/CVE-2026-86289/index.md","name":"CVE-2026-86289","record":{"aliases":["GHSA-c2q9-58w2-gjg4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference server","requires_auth":"none","summary":"Remote attackers can trigger an integer overflow in the GGUF decoder, potentially causing denial of service or code execution in Ollama.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-189","name":null}],"description":"A vulnerability was found in Ollama up to 0.31.1. This issue affects the function readGGUFV1String of the file fs/ggml/gguf.go of the component GGUF Decoder. Performing a manipulation results in integer overflow. The attack is possible to be carried out remotely. The exploit has been made public and could be used. Upgrading to version 0.31.2-rc1 is capable of addressing this issue. The patch is named 67b6a1c2d45321e0cb3c04a18073f9818de7724b. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Ollama GGUF Decoder gguf.go readGGUFV1String integer overflow","id":"CVE-2026-86289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":0,"n_references":9,"next":{"headline":"SourceCodester Online Voting System ajax.php save_category sql injection","id":"CVE-2026-86290"},"packages":[],"prev":{"headline":"ModelCloud GPTQModel Triton dequantization kernel tritonv2.py out-of-bounds","id":"CVE-2026-86288"},"products":["Ollama"],"published":"2026-09-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-11","vendors":["n/a"]},"summary":"Remote attackers can trigger an integer overflow in the GGUF decoder, potentially causing denial of service or code execution in Ollama.","url":"https://insights.sbomify.com/CVE-2026-86289/"}