# CVE-2026-8630: justhtml before 1.12.0 Mutation XSS via Raw Text Elements

> Attackers can inject arbitrary HTML via mutation XSS in justhtml when custom policies retain raw-text elements like style or script.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 Aug 2026
- **Updated:** 26 Aug 2026
- **Also known as:** GHSA-qvc2-mg72-jjhx, GHSA-rc3v-3cc7-h7h5

## What is CVE-2026-8630?

CVE-2026-8630 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

justhtml before 1.12.0 (versions <= 1.11.0) contains a mutation cross-site scripting (mXSS) vulnerability in the serialization of raw-text elements such as <style> and <script>. When a DOM tree is processed by sanitize_dom() using a custom policy that keeps these elements, text nodes inside them are serialized literally without escaping, allowing attacker-controlled text containing the matching closing tag sequence to break out of the raw-text context and inject arbitrary HTML into the serialized output. The default sanitization policy is not affected because it drops the contents of style and script.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-8630?

2 open source packages ship an affected version, including justhtml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `justhtml` | PyPI | All versions | 1.12.0 |
| `justhtml` | PyPI | All versions | 1.12.0 |

## How do I fix CVE-2026-8630?

Upgrade justhtml to 1.12.0 or later.

## Is CVE-2026-8630 being exploited?

There is no known exploitation of CVE-2026-8630 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8630 and fix it if it is affected.

What it is: CVE-2026-8630 is a medium-severity cross-site scripting vulnerability in EmilStenstrom justhtml, published on 23 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-8630 in the wild and no public exploit code.

Affected packages and fixed versions:
- justhtml (PyPI): affected all versions; fixed in 1.12.0
- justhtml (PyPI): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8630/ (Markdown: https://insights.sbomify.com/CVE-2026-8630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8630
- OSV: https://osv.dev/vulnerability/CVE-2026-8630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8630/
Summaries are generated and may contain mistakes; the official description above is the record.
