CVE-2026-86429 commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes
An attacker can cause denial of service via CPU exhaustion in the commonmark library if specific optional extensions are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86429?
CVE-2026-86429 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The league/commonmark (thephpleague/commonmark) library in versions >= 1.5.0 and < 2.9.1 contains quadratic parsing complexity in its SmartPunctExtension and AttributesExtension. When either extension is explicitly registered on the Environment (they are not enabled by default and are excluded from the standard CommonMark and GitHub-Flavored Markdown converters), an unauthenticated attacker can submit small, specially crafted Markdown documents — such as text alternating with unpaired quotes, contiguous runs of block-level attribute blocks, or repeated class attributes — to trigger disproportionate CPU consumption and cause a denial of service. Fixed in 2.9.1.
Weakness: CWE-407
Which versions are affected by CVE-2026-86429?
2 open source packages ship an affected version, including league/commonmark. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
league/commonmark Packagist | From 1.5.0 | 2.9.1 |
league/commonmark Packagist | From 1.5.0 | 2.9.1 |
Products include Thephpleague Commonmark.
How do I fix CVE-2026-86429?
Upgrade league/commonmark to 2.9.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-86429 being exploited?
There is no known exploitation of CVE-2026-86429 in the wild and no public exploit code.
Other vulnerabilities in thephpleague commonmark
- CVE-2026-86428 commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes
- CVE-2026-86430 league/commonmark before 2.9.1 Denial of Service via parsing
- CVE-2026-86431 commonmark before 2.9.1 XSS via AttributesExtension form feed bypass
- CVE-2026-33347 league/commonmark has an embed extension allowed_domains bypass
- CVE-2019-10010 Moderate severity vulnerability that affects league/commonmark
Sources
Also known as DEBIAN-CVE-2026-86429, GHSA-7x8h-jg2x-pjm5, GHSA-jjv6-8j6v-6j52, UBUNTU-CVE-2026-86429.