# CVE-2026-86430: league/commonmark before 2.9.1 Denial of Service via parsing

> Attackers can cause denial of service by submitting crafted Markdown input that triggers excessive CPU consumption in the league/commonmark library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-86430, GHSA-hxrj-xxg4-w3qp, GHSA-j8pm-gj4c-rq4x, UBUNTU-CVE-2026-86430

## What is CVE-2026-86430?

CVE-2026-86430 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark versions before 2.9.1 contain multiple denial of service vulnerabilities in fenced code block detection, reference link label lookup, and emphasis delimiter processing that perform super-linear work on crafted input. Attackers can submit specially crafted Markdown with long backtick runs, nested brackets, or delimiter sequences to consume disproportionate CPU time and prevent legitimate requests from completing.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-86430?

2 open source packages ship an affected version, including league/commonmark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 0.6.0 | 2.9.1 |
| `league/commonmark` | Packagist | From 0.6.0 | 2.9.1 |

Products: Thephpleague Commonmark.

## How do I fix CVE-2026-86430?

Upgrade league/commonmark to 2.9.1 or later.

## Is CVE-2026-86430 being exploited?

There is no known exploitation of CVE-2026-86430 in the wild and no public exploit code.

## Other vulnerabilities in thephpleague commonmark

- [CVE-2026-86428](https://insights.sbomify.com/CVE-2026-86428/): commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes (high 8.7)
- [CVE-2026-86429](https://insights.sbomify.com/CVE-2026-86429/): commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes (high 8.7)
- [CVE-2026-86431](https://insights.sbomify.com/CVE-2026-86431/): commonmark before 2.9.1 XSS via AttributesExtension form feed bypass (medium 6.9)
- [CVE-2026-33347](https://insights.sbomify.com/CVE-2026-33347/): league/commonmark has an embed extension allowed_domains bypass (medium 6.3)
- [CVE-2019-10010](https://insights.sbomify.com/CVE-2019-10010/): Moderate severity vulnerability that affects league/commonmark (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86430 and fix it if it is affected.

What it is: CVE-2026-86430 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86430 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 0.6.0; fixed in 2.9.1
- league/commonmark (Packagist): affected from 0.6.0; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86430/ (Markdown: https://insights.sbomify.com/CVE-2026-86430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86430
- OSV: https://osv.dev/vulnerability/CVE-2026-86430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86430/
Summaries are generated and may contain mistakes; the official description above is the record.
