# CVE-2026-86431: commonmark before 2.9.1 XSS via AttributesExtension form feed bypass

> Attackers can inject malicious scripts into rendered HTML by bypassing attribute filters in the commonmark library's AttributesExtension.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-86431, GHSA-f8fg-pg57-v4j8, GHSA-m24x-mf52-x8gc, UBUNTU-CVE-2026-86431

## What is CVE-2026-86431?

CVE-2026-86431 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark (thephpleague/commonmark) versions >= 2.7.0 and < 2.9.1 contain a cross-site scripting vulnerability in the AttributesExtension. Prefixing an attribute name with a single U+000C form feed byte (e.g. {\x0Conclick="alert(1)"}) bypasses the AttributesHelper::filterAttributes() 'on*' event-handler filter because PHP's trim() does not strip U+000C, causing the attribute to be written verbatim into the output where browsers parse it as a genuine event handler. The same prefix also defeats the allow_unsafe_links check, allowing javascript: URIs through href/src attributes even when allow_unsafe_links is false. Exploitation requires processing untrusted Markdown with the AttributesExtension enabled; the injected script executes when the rendered HTML is viewed. Fixed in 2.9.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-86431?

2 open source packages ship an affected version, including league/commonmark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 2.7.0 | 2.9.1 |
| `league/commonmark` | Packagist | From 2.7.0 | 2.9.1 |

Products: Thephpleague Commonmark.

## How do I fix CVE-2026-86431?

Upgrade league/commonmark to 2.9.1 or later.

## Is CVE-2026-86431 being exploited?

There is no known exploitation of CVE-2026-86431 in the wild and no public exploit code.

## Other vulnerabilities in thephpleague commonmark

- [CVE-2026-86428](https://insights.sbomify.com/CVE-2026-86428/): commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes (high 8.7)
- [CVE-2026-86429](https://insights.sbomify.com/CVE-2026-86429/): commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes (high 8.7)
- [CVE-2026-86430](https://insights.sbomify.com/CVE-2026-86430/): league/commonmark before 2.9.1 Denial of Service via parsing (high 8.7)
- [CVE-2026-33347](https://insights.sbomify.com/CVE-2026-33347/): league/commonmark has an embed extension allowed_domains bypass (medium 6.3)
- [CVE-2019-10010](https://insights.sbomify.com/CVE-2019-10010/): Moderate severity vulnerability that affects league/commonmark (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86431 and fix it if it is affected.

What it is: CVE-2026-86431 is a medium-severity cross-site scripting vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86431 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 2.7.0; fixed in 2.9.1
- league/commonmark (Packagist): affected from 2.7.0; fixed in 2.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86431/ (Markdown: https://insights.sbomify.com/CVE-2026-86431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86431
- OSV: https://osv.dev/vulnerability/CVE-2026-86431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86431/
Summaries are generated and may contain mistakes; the official description above is the record.
