# CVE-2026-86434: commonmark 2.0.0 through 2.8.3 Denial of Service via Slug Collision

> An attacker can cause excessive CPU consumption and denial of service in the commonmark library by exploiting a slug collision algorithm flaw when specific extensions are enabled.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-86434, GHSA-jcmh-chhq-rh2x, GHSA-mh25-x5hq-wrqp, UBUNTU-CVE-2026-86434

## What is CVE-2026-86434?

CVE-2026-86434 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark versions >= 2.0.0 and < 2.8.4 (patched in 2.9.0) contain a denial of service vulnerability in UniqueSlugNormalizer::normalize(), which restarts its numeric-suffix search from 1 on every slug collision, resulting in O(K^2) time complexity for K headings that collapse to the same base slug. The vulnerable path is reached when HeadingPermalinkExtension, FootnoteExtension, or TableOfContentsExtension is registered. An unauthenticated attacker can force many headings onto a single base slug (e.g., via empty ATX headings, identical heading text, or punctuation-only headings) in a small Markdown document, consuming excessive CPU and denying service.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-86434?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | From 2.0.0 | 2.9.0 |
| `league/commonmark` | Packagist | From 2.0.0 | 2.9.0 |

## How do I fix CVE-2026-86434?

Upgrade league/commonmark to 2.9.0 or later.

## Is CVE-2026-86434 being exploited?

There is no known exploitation of CVE-2026-86434 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86434 and fix it if it is affected.

What it is: CVE-2026-86434 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 7 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86434 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.9.0
- league/commonmark (Packagist): affected from 2.0.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86434/ (Markdown: https://insights.sbomify.com/CVE-2026-86434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86434
- OSV: https://osv.dev/vulnerability/CVE-2026-86434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86434/
Summaries are generated and may contain mistakes; the official description above is the record.
