# CVE-2026-86439: knowns before 0.30.0 Path Traversal via MCP doc and memory tools

> Attackers can exploit path traversal in knowns MCP tools to read, create, overwrite, or delete arbitrary files outside the project directory.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** GHSA-9gfj-28hw-jchp

## What is CVE-2026-86439?

CVE-2026-86439 is a high-severity path traversal vulnerability in knowns-dev knowns, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

knowns versions before 0.30.0 fail to validate filesystem paths in MCP tool arguments, allowing attackers to read, create, overwrite and delete files outside the project directory. Attackers can supply path arguments containing directory traversal sequences to access arbitrary Markdown files accessible to the server process.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-86439?

2 open source packages ship an affected version, including knowns.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `knowns` | npm | All versions | 0.30.0 |
| `knowns` | npm | All versions | 0.30.0 |

## How do I fix CVE-2026-86439?

Upgrade knowns to 0.30.0 or later.

## Is CVE-2026-86439 being exploited?

There is no known exploitation of CVE-2026-86439 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86439 and fix it if it is affected.

What it is: CVE-2026-86439 is a high-severity path traversal vulnerability in knowns-dev knowns, published on 7 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86439 in the wild and no public exploit code.

Affected packages and fixed versions:
- knowns (npm): affected all versions; fixed in 0.30.0
- knowns (npm): affected all versions; fixed in 0.30.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86439/ (Markdown: https://insights.sbomify.com/CVE-2026-86439/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86439
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86439
- OSV: https://osv.dev/vulnerability/CVE-2026-86439

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86439/
Summaries are generated and may contain mistakes; the official description above is the record.
