CVE-2026-86460 Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Attackers can execute arbitrary Cypher queries via FIQL search in Apache Syncope's Neo4j persistence layer, requiring Neo4j configuration.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-86460?
CVE-2026-86460 is a critical code injection vulnerability in Apache Syncope, published on 14 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions.
This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2.
Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.
Weakness: CWE-89
Which versions are affected by CVE-2026-86460?
How do I fix CVE-2026-86460?
No fix has been published for CVE-2026-86460 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-86460 being exploited?
There is no known exploitation of CVE-2026-86460 in the wild and no public exploit code.
Sources
Also known as GHSA-h6hm-vrjv-9gv4.