# CVE-2026-86462: Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions

> Attackers with stolen session cookies retain access after password changes because the FAB Admin PATCH endpoint fails to invalidate database-backed sessions.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-QU51579, GHSA-5j5v-7fmw-4hvh

## What is CVE-2026-86462?

CVE-2026-86462 is a critical vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Airflow FAB provider: changing a user's password through the Admin user-edit PATCH endpoint does not invalidate that user's existing database-backed sessions. An attacker who already holds a copy of the victim's session cookie keeps full access as that user after the password change, so the password reset does not evict them. Affects deployments using the FAB auth manager with database-backed sessions; an administrator (or the user themselves) performing a routine password change is the trigger, and no attacker interaction with the endpoint is needed.

This is a second, independent route to the outcome addressed by CVE-2026-82311, which corrected an identifier comparison in the session-invalidation helper. That fix does not repair this endpoint, because the PATCH path never calls the helper at all. Deployments that applied the CVE-2026-82311 fix must also upgrade for this one.

Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, which fixes the issue.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-86462?

It affects 1 product.


Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-86462?

Upgrade to a fixed version.

## Is CVE-2026-86462 being exploited?

There is no known exploitation of CVE-2026-86462 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)
- [CVE-2026-86466](https://insights.sbomify.com/CVE-2026-86466/): Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86462 and fix it if it is affected.

What it is: CVE-2026-86462 is a critical vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86462 in the wild and no public exploit code.

Affected product: Apache Airflow FAB provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86462/ (Markdown: https://insights.sbomify.com/CVE-2026-86462/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86462
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86462
- OSV: https://osv.dev/vulnerability/CVE-2026-86462

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86462/
Summaries are generated and may contain mistakes; the official description above is the record.
