# CVE-2026-86466: Apache Airflow FAB provider: FAB Authentik provider: id_token issuer/audience not validated

> Attackers can authenticate to Apache Airflow using valid tokens from other applications on the same Authentik instance due to missing issuer and audience validation.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** CLEANSTART-2026-RR24550, GHSA-6fx3-rxq6-j8w2

## What is CVE-2026-86466?

CVE-2026-86466 is a high-severity authentication bypass vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow FAB provider: the Authentik OAuth path in the FAB auth manager does not validate the issuer or audience claims of the id_token it accepts. An attacker holding a token that the same Authentik identity provider minted for a different client application can present it to Airflow and be authenticated as the user it names, because the audience claim is never checked. Affects deployments using the FAB auth manager with Authentik OAuth where the same Authentik instance also serves other applications; the attacker needs a valid token for any of those other applications, not for Airflow.

CVE-2026-75156 corrected the same missing validation on the Azure AD path in this file; the Authentik path was left unchanged and is fixed here. Deployments that applied the CVE-2026-75156 fix and use Authentik must also upgrade for this one.

Users of apache-airflow-providers-fab are recommended to upgrade to version 3.9.0 or later, which fixes the issue.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-86466?

It affects 1 product.


Products: Apache Apache-Airflow-Providers-Fab.

## How do I fix CVE-2026-86466?

Upgrade to a fixed version.

## Is CVE-2026-86466 being exploited?

There is no known exploitation of CVE-2026-86466 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow FAB provider

- [CVE-2026-82311](https://insights.sbomify.com/CVE-2026-82311/): Security feature bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2026-59243](https://insights.sbomify.com/CVE-2026-59243/): Auth bypass in Apache Airflow FAB provider (critical 9.8)
- [CVE-2024-42447](https://insights.sbomify.com/CVE-2024-42447/): Apache Airflow Providers FAB: FAB provider 1.2.1 and 1.2.0 did not let user to logout for Airflow (critical 9.8)
- [CVE-2026-86462](https://insights.sbomify.com/CVE-2026-86462/): Apache Airflow FAB provider: FAB Admin password PATCH does not invalidate database-backed sessions (critical 9.1)
- [CVE-2026-75156](https://insights.sbomify.com/CVE-2026-75156/): Auth bypass in Apache Airflow FAB provider (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86466 and fix it if it is affected.

What it is: CVE-2026-86466 is a high-severity authentication bypass vulnerability in Apache Airflow FAB provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86466 in the wild and no public exploit code.

Affected product: Apache Airflow FAB provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86466/ (Markdown: https://insights.sbomify.com/CVE-2026-86466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86466
- OSV: https://osv.dev/vulnerability/CVE-2026-86466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86466/
Summaries are generated and may contain mistakes; the official description above is the record.
