# CVE-2026-86471: Apache CouchDB: Admin credentials leading to code execution as operating system user


- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L/E:A/S:N/AU:Y/R:U/V:C/RE:M/U:Red`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 20 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** BIT-couchdb-2026-86471, GHSA-885r-pfpm-ch95, UBUNTU-CVE-2026-86471

## What is CVE-2026-86471?

CVE-2026-86471 is a critical vulnerability in Apache CouchDB, published on 20 Oct 2026. 

### Official description

An unvalidated runtime configuration value in Apache CouchDB 3.5.2 and below on all platforms allows a CouchDB server admin to run arbitrary shell commands as the CouchDB operating system user.

Users are recommended to upgrade to version 3.5.3, which fixes this issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-86471?

1 open source package ship an affected version, including couchdb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `couchdb` | Bitnami | All versions | 3.5.3 |

## How do I fix CVE-2026-86471?

Upgrade couchdb to 3.5.3 or later.

## Is CVE-2026-86471 being exploited?

There is no known exploitation of CVE-2026-86471 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86471 and fix it if it is affected.

What it is: CVE-2026-86471 is a critical vulnerability in Apache CouchDB, published on 20 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-86471 in the wild and no public exploit code.

Affected packages and fixed versions:
- couchdb (Bitnami): affected all versions; fixed in 3.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86471/ (Markdown: https://insights.sbomify.com/CVE-2026-86471/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86471
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86471
- OSV: https://osv.dev/vulnerability/CVE-2026-86471

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86471/
Summaries are generated and may contain mistakes; the official description above is the record.
