CVE-2026-86472 fast-uri vulnerable to inconsistent host case normalization via percent-encoded octets
Attackers can bypass host allowlists or denylists in applications using fast-uri by exploiting inconsistent case normalization of percent-encoded hostnames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86472?
CVE-2026-86472 is a medium-severity vulnerability in fast-uri, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
fast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv. In versions before 2.4.7, from 3.0.0 through 3.1.7, and from 4.0.0 through 4.1.4, fast-uri folds the host to lowercase before it percent-decodes the host, so a percent-encoded uppercase octet such as %41 decodes to a literal A that is never folded. For a scheme-relative reference such as //host there is no scheme, so the host canonicalization that would normally repair this does not run, and parse, normalize, and equal then disagree on the same host. An application that makes a case-sensitive host decision on fast-uri output, for example a host allowlist or denylist that compares the parsed host or uses equal, can be steered past the check with a percent-encoded uppercase octet, and because hostnames are case-insensitive in DNS and HTTP the evading spelling still reaches the host the check meant to gate. The issue is fixed in fast-uri 2.4.7, 3.1.8, and 4.1.5, and users should upgrade to one of those versions or later. As a workaround, compare hosts case-insensitively by lowercasing the parsed host before any allowlist or denylist decision.
Weakness: CWE-178
Which versions are affected by CVE-2026-86472?
6 open source packages ship an affected version, including fast-uri.
| Package | Affected | Fixed in |
|---|---|---|
fast-uri npm | All versions | 2.4.7 |
fast-uri npm | All versions | 2.4.7 |
fast-uri npm | From 3.0.0 | 3.1.8 |
fast-uri npm | From 3.0.0 | 3.1.8 |
fast-uri npm | From 4.0.0 | 4.1.5 |
fast-uri npm | From 4.0.0 | 4.1.5 |
How do I fix CVE-2026-86472?
Upgrade fast-uri to a fixed version for your release line: 2.4.7, 3.1.8 or 4.1.5.
Is CVE-2026-86472 being exploited?
There is no known exploitation of CVE-2026-86472 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-TS29209, CLEANSTART-2026-YH79720, CLSA-2026-1790854655, CLSA-2026-1790854674, CLSA-2026-1790856979, CLSA-2026-1790856982 and 47 more.