# CVE-2026-86472: fast-uri vulnerable to inconsistent host case normalization via percent-encoded octets

> Attackers can bypass host allowlists or denylists in applications using fast-uri by exploiting inconsistent case normalization of percent-encoded hostnames.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** CLEANSTART-2026-TS29209, CLEANSTART-2026-YH79720, CLSA-2026-1790854655, CLSA-2026-1790854674, CLSA-2026-1790856979, CLSA-2026-1790856982, CLSA-2026-1790863075, CLSA-2026-1790864817, CLSA-2026-1790869753, CLSA-2026-1790941624, CLSA-2026-1791028075, CLSA-2026-1791050097, CLSA-2026-1791626480, CLSA-2026-1791627179, CLSA-2026-1791814987, DEBIAN-CVE-2026-86472, ECHO-b691-831d-dcfd, GHSA-hrr3-gc8f-f4qj, MINI-36x7-pfw4-pjpv, MINI-3vc7-mxch-2r9x, MINI-5hhf-mq6w-qfvv, MINI-62jp-7fxp-gh62, MINI-6354-p8c8-p8hr, MINI-6rx2-pg6j-jw27, MINI-6xr7-f2qp-6c36, MINI-86qp-x86w-cg8v, MINI-c2f5-wj7q-c5hp, MINI-c7q4-hwww-97p6, MINI-ccgg-h28h-fjhx, MINI-ccpw-5p4m-g2qr, MINI-gwr4-9772-63vj, MINI-h34c-g9rx-jxpp, MINI-h5hc-f8jg-mxvr, MINI-hg6r-phj4-35w2, MINI-hm4p-w28v-vfrc, MINI-j77w-7r74-gxhp, MINI-jf63-v2v6-fqpw, MINI-jq9v-7pcp-6w96, MINI-jww4-x5h3-hj48, MINI-mc4w-fgw5-43j2, MINI-p875-g26c-g32h, MINI-q272-vj5g-c9rj, MINI-q7hf-8j5r-wm3v, MINI-q8gq-x22m-vp2v, MINI-qxx7-44fp-x99w, MINI-v5p3-3q26-rm55, MINI-vq9c-mqwr-qghr, MINI-w835-2j5c-c36p, MINI-wp26-28gg-8wwq, MINI-wqpw-5hjx-ccmx, MINI-x3p2-2gj2-6qx9, MINI-xpg6-h635-pwxx, UBUNTU-CVE-2026-86472

## What is CVE-2026-86472?

CVE-2026-86472 is a medium-severity vulnerability in fast-uri, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

fast-uri is a dependency-free RFC 3986 URI parser for Node.js, used by Fastify and ajv. In versions before 2.4.7, from 3.0.0 through 3.1.7, and from 4.0.0 through 4.1.4, fast-uri folds the host to lowercase before it percent-decodes the host, so a percent-encoded uppercase octet such as %41 decodes to a literal A that is never folded. For a scheme-relative reference such as //host there is no scheme, so the host canonicalization that would normally repair this does not run, and parse, normalize, and equal then disagree on the same host. An application that makes a case-sensitive host decision on fast-uri output, for example a host allowlist or denylist that compares the parsed host or uses equal, can be steered past the check with a percent-encoded uppercase octet, and because hostnames are case-insensitive in DNS and HTTP the evading spelling still reaches the host the check meant to gate. The issue is fixed in fast-uri 2.4.7, 3.1.8, and 4.1.5, and users should upgrade to one of those versions or later. As a workaround, compare hosts case-insensitively by lowercasing the parsed host before any allowlist or denylist decision.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-86472?

6 open source packages ship an affected version, including fast-uri.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fast-uri` | npm | All versions | 2.4.7 |
| `fast-uri` | npm | All versions | 2.4.7 |
| `fast-uri` | npm | From 3.0.0 | 3.1.8 |
| `fast-uri` | npm | From 3.0.0 | 3.1.8 |
| `fast-uri` | npm | From 4.0.0 | 4.1.5 |
| `fast-uri` | npm | From 4.0.0 | 4.1.5 |

## How do I fix CVE-2026-86472?

Upgrade fast-uri to a fixed version for your release line: 2.4.7, 3.1.8 or 4.1.5.

## Is CVE-2026-86472 being exploited?

There is no known exploitation of CVE-2026-86472 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86472 and fix it if it is affected.

What it is: CVE-2026-86472 is a medium-severity vulnerability in fast-uri, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86472 in the wild and no public exploit code.

Affected packages and fixed versions:
- fast-uri (npm): affected all versions; fixed in 2.4.7
- fast-uri (npm): affected all versions; fixed in 2.4.7
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.8
- fast-uri (npm): affected from 3.0.0; fixed in 3.1.8
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.5
- fast-uri (npm): affected from 4.0.0; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86472/ (Markdown: https://insights.sbomify.com/CVE-2026-86472/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86472
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86472
- OSV: https://osv.dev/vulnerability/CVE-2026-86472

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86472/
Summaries are generated and may contain mistakes; the official description above is the record.
