CVE-2026-86507 Apache Roller: Stored XSS in comment moderation via comment author URL

Medium 6.1 Published Updated

An attacker can inject malicious scripts via comment author URLs, potentially compromising moderator sessions in Apache Roller.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-86507?

CVE-2026-86507 is a medium-severity cross-site scripting vulnerability in Apache Roller, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Improper neutralization of input in Apache Roller 6.1.5 allows an anonymous remote attacker to store a crafted comment-author URL that can execute script in the session of a weblog moderator or global administrator when the comment management page is viewed. This affects sites that permit comments on at least one weblog and whose moderator subsequently reviews the submitted comment; no non-default server setting is required. Users are recommended to upgrade to Apache Roller 6.1.6 or later.

Weakness: CWE-79

Which versions are affected by CVE-2026-86507?

How do I fix CVE-2026-86507?

No fix has been published for CVE-2026-86507 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-86507 being exploited?

There is no known exploitation of CVE-2026-86507 in the wild and no public exploit code.

Sources

Also known as GHSA-4hv4-w9v7-8mr5.

Is CVE-2026-86507 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free