CVE-2026-86533 Revoked session accepted because the session jti is never checked in AshAuthentication and AshAuthentication Phoenix
Attackers can maintain access using revoked sessions because the library fails to validate session identifiers, allowing unauthorized account access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86533?
CVE-2026-86533 is a critical authentication bypass vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Insufficient Session Expiration vulnerability in team-alembic AshAuthentication and AshAuthentication Phoenix allows a revoked session to remain fully authenticated.
A resource configured with session_identifier :jti and require_token_presence_for_authentication? disabled stores its session value as <jti>:<subject>. The jti is there so that signing out can revoke that one session. Neither reader consults it: AshAuthentication.Plug.Helpers.authenticate_resource_from_session/4 and AshAuthentication.Phoenix.LiveSession.on_mount/4 both split the value with split_identifier/2, discard the jti and pass the bare subject to AshAuthentication.subject_to_user/3, which reloads the record. The token-presence branch of each function does check its token, calling AshAuthentication.TokenResource.Actions.get_token/3 with the jti and the purpose user. Because the revocation record is never read, neither its revoked state nor its expiry constrains the session, so a session captured before sign-out keeps working.
This issue affects ash_authentication: from 4.9.1 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14; ash_authentication_phoenix: from 2.10.0 before 2.17.4 and from 3.0.0-rc.0 before 3.0.0-rc.11.
Weakness: CWE-613
Which versions are affected by CVE-2026-86533?
2 open source packages ship an affected version, including ash_authentication and ash_authentication_phoenix.
| Package | Affected | Fixed in |
|---|---|---|
ash_authentication Hex | From 4.9.1 | 4.15.0, 5.0.0-rc.14 |
ash_authentication_phoenix Hex | From 2.10.0 | 2.17.4, 3.0.0-rc.11 |
How do I fix CVE-2026-86533?
Upgrade ash_authentication to a fixed version for your release line: 4.15.0 or 5.0.0-rc.14.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-86533 being exploited?
There is no known exploitation of CVE-2026-86533 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-86533, GHSA-m6x4-4gvp-xwjr.