# CVE-2026-8657: jsondiffpatch patch APIs are vulnerable to prototype pollution

> Prototype pollution in jsondiffpatch allows attackers to modify Object.prototype via crafted patches, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 May 2026
- **Updated:** 23 Aug 2026
- **Also known as:** GHSA-j4fx-xxwh-2485, MINI-3cxv-875p-rw48, MINI-4cmc-wxvv-7p58, MINI-6mcx-59xh-qh64, MINI-98pm-vvpq-8c9h, MINI-q845-f2vr-g2qf, MINI-qcjh-mcmp-p6mx, MINI-v7fh-pcpv-hg9h, MINI-vj5p-p43r-27pc, ROOT-APP-NPM-CVE-2026-8657

## What is CVE-2026-8657?

CVE-2026-8657 is a high-severity vulnerability in jsondiffpatch, published on 16 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package jsondiffpatch before 0.7.6 are vulnerable to Prototype Pollution via the jsondiffpatch.patch() and jsondiffpatch/formatters/jsonpatch.patch() APIs. An attacker can perform prototype pollution by supplying crafted delta or JSON Patch documents, as attacker-controlled property names and path segments are used to traverse and modify objects without restricting access to special properties like __proto__ or constructor.prototype, allowing modification of Object.prototype.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-8657?

2 open source packages ship an affected version, including jsondiffpatch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsondiffpatch` | npm | All versions | 0.7.6 |
| `jsondiffpatch` | npm | All versions | 0.7.6 |

## How do I fix CVE-2026-8657?

Upgrade jsondiffpatch to 0.7.6 or later.

## Is CVE-2026-8657 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8657 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8657 and fix it if it is affected.

What it is: CVE-2026-8657 is a high-severity vulnerability in jsondiffpatch, published on 16 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-8657 exists.

Affected packages and fixed versions:
- jsondiffpatch (npm): affected all versions; fixed in 0.7.6
- jsondiffpatch (npm): affected all versions; fixed in 0.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8657/ (Markdown: https://insights.sbomify.com/CVE-2026-8657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8657
- OSV: https://osv.dev/vulnerability/CVE-2026-8657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8657/
Summaries are generated and may contain mistakes; the official description above is the record.
