CVE-2026-86597 Sensitive information written to logs by Snowflake drivers
Snowflake drivers leak sensitive credentials and keys to logs, allowing attackers with log access to authenticate to accounts or access cloud storage.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-86597?
CVE-2026-86597 is a medium-severity vulnerability in Snowflake Connector for Python, published on 8 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. Successful exploitation requires read access to the log destination, and impact is bounded by credential lifetime and object scope. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and snowflake-jdbc-thin), Snowflake Node.js Driver v3.3.0, Snowflake PHP PDO Driver v4.2.0, and Snowflake ODBC Driver v3.20.0. Users must manually upgrade and should securely delete previously generated diagnostic logs containing sensitive information where retention is not required.
Weakness: CWE-532
Which versions are affected by CVE-2026-86597?
17 open source packages ship an affected version, including snowflake-connector-python, github.com/snowflakedb/gosnowflake and github.com/snowflakedb/gosnowflake/v2.
| Package | Affected | Fixed in |
|---|---|---|
snowflake-connector-python PyPI | All versions | 4.7.3 |
snowflake-connector-python PyPI | All versions | 4.7.3 |
snowflake-connector-python PyPI | All versions | 4.7.3 |
github.com/snowflakedb/gosnowflake Go | All versions | None |
github.com/snowflakedb/gosnowflake Go | All versions to 1.19.1 | None |
github.com/snowflakedb/gosnowflake Go | All versions to 1.19.1 | None |
11 more packages
github.com/snowflakedb/gosnowflake/v2 Go | All versions | 2.2.0 |
github.com/snowflakedb/gosnowflake/v2 Go | All versions | 2.2.0 |
github.com/snowflakedb/gosnowflake/v2 Go | All versions | 2.2.0 |
net.snowflake:snowflake-jdbc Maven | All versions | 4.3.4 |
net.snowflake:snowflake-jdbc Maven | All versions | 4.3.4 |
net.snowflake:snowflake-jdbc-fips Maven | All versions | 4.3.4 |
net.snowflake:snowflake-jdbc-fips Maven | All versions | 4.3.4 |
net.snowflake:snowflake-jdbc-thin Maven | All versions | 4.3.4 |
net.snowflake:snowflake-jdbc-thin Maven | All versions | 4.3.4 |
snowflake-sdk npm | All versions | 3.3.0 |
snowflake-sdk npm | All versions | 3.3.0 |
How do I fix CVE-2026-86597?
Upgrade snowflake-connector-python to 4.7.3 or later.
Is CVE-2026-86597 being exploited?
There is no known exploitation of CVE-2026-86597 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-BX63294, CLEANSTART-2026-HL90010, ECHO-8628-ddd7-76a8, GHSA-qqj6-54q6-cxv6, GO-2026-6665, MINI-29vj-ghj7-rpq3 and 20 more.