# CVE-2026-86597: Sensitive information written to logs by Snowflake drivers

> Snowflake drivers leak sensitive credentials and keys to logs, allowing attackers with log access to authenticate to accounts or access cloud storage.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** CLEANSTART-2026-BX63294, CLEANSTART-2026-HL90010, ECHO-8628-ddd7-76a8, GHSA-qqj6-54q6-cxv6, GO-2026-6665, MINI-29vj-ghj7-rpq3, MINI-338r-hrhm-crrj, MINI-3jpp-6wxm-p2m7, MINI-3mxp-gvgm-23xq, MINI-3x9v-wrfv-684w, MINI-47wf-5hhr-rxhx, MINI-4h4p-8gh7-7m23, MINI-7jpm-gpj3-84vg, MINI-7v4w-cqjg-45r2, MINI-856p-c35w-p239, MINI-9chr-chj6-qg2r, MINI-fqhh-28fc-2xfj, MINI-g26p-xwmq-xw92, MINI-h8h6-wr8q-cj5h, MINI-mq5x-mg7j-wrr5, MINI-pxf8-qr9j-j9gg, MINI-rpq7-cgvp-94fp, MINI-vpcg-45rw-gxmc, MINI-w432-2mv3-7q36, MINI-wj99-p3pg-ph3c, PYSEC-2026-4301

## What is CVE-2026-86597?

CVE-2026-86597 is a medium-severity vulnerability in Snowflake Connector for Python, published on 8 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Insertion of sensitive information into log files in the Snowflake Python, Go, JDBC, Node.js, PHP PDO, and ODBC drivers allowed authentication tokens, query-result encryption keys, pre-signed cloud-storage URLs, and SAML assertions to be written to diagnostic logs in circumstances where the available log redaction did not cover all affected log paths and data types. An attacker with read access to the log destination, whether the local filesystem, a log aggregation service, or a CI/CD artifact store, could obtain credentials and decryption keys that, if still valid at the time of access, could be used to authenticate to the corresponding Snowflake account or cloud-storage object. Successful exploitation requires read access to the log destination, and impact is bounded by credential lifetime and object scope. The fix is available in Snowflake Connector for Python v4.7.3, Snowflake Go Driver v2.2.0, Snowflake JDBC Driver v4.3.4 (including the snowflake-jdbc-fips and snowflake-jdbc-thin), Snowflake Node.js Driver v3.3.0, Snowflake PHP PDO Driver v4.2.0, and Snowflake ODBC Driver v3.20.0. Users must manually upgrade and should securely delete previously generated diagnostic logs containing sensitive information where retention is not required.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2026-86597?

17 open source packages ship an affected version, including snowflake-connector-python, github.com/snowflakedb/gosnowflake and github.com/snowflakedb/gosnowflake/v2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snowflake-connector-python` | PyPI | All versions | 4.7.3 |
| `snowflake-connector-python` | PyPI | All versions | 4.7.3 |
| `snowflake-connector-python` | PyPI | All versions | 4.7.3 |
| `github.com/snowflakedb/gosnowflake` | Go | All versions | None |
| `github.com/snowflakedb/gosnowflake` | Go | All versions to 1.19.1 | None |
| `github.com/snowflakedb/gosnowflake` | Go | All versions to 1.19.1 | None |
| `github.com/snowflakedb/gosnowflake/v2` | Go | All versions | 2.2.0 |
| `github.com/snowflakedb/gosnowflake/v2` | Go | All versions | 2.2.0 |
| `github.com/snowflakedb/gosnowflake/v2` | Go | All versions | 2.2.0 |
| `net.snowflake:snowflake-jdbc` | Maven | All versions | 4.3.4 |
| `net.snowflake:snowflake-jdbc` | Maven | All versions | 4.3.4 |
| `net.snowflake:snowflake-jdbc-fips` | Maven | All versions | 4.3.4 |
| `net.snowflake:snowflake-jdbc-fips` | Maven | All versions | 4.3.4 |
| `net.snowflake:snowflake-jdbc-thin` | Maven | All versions | 4.3.4 |
| `net.snowflake:snowflake-jdbc-thin` | Maven | All versions | 4.3.4 |
| `snowflake-sdk` | npm | All versions | 3.3.0 |
| `snowflake-sdk` | npm | All versions | 3.3.0 |

## How do I fix CVE-2026-86597?

Upgrade snowflake-connector-python to 4.7.3 or later.

## Is CVE-2026-86597 being exploited?

There is no known exploitation of CVE-2026-86597 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86597 and fix it if it is affected.

What it is: CVE-2026-86597 is a medium-severity vulnerability in Snowflake Connector for Python, published on 8 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86597 in the wild and no public exploit code.

Affected packages and fixed versions:
- snowflake-connector-python (PyPI): affected all versions; fixed in 4.7.3
- snowflake-connector-python (PyPI): affected all versions; fixed in 4.7.3
- snowflake-connector-python (PyPI): affected all versions; fixed in 4.7.3
- github.com/snowflakedb/gosnowflake (Go): affected all versions; no fix listed
- github.com/snowflakedb/gosnowflake (Go): affected all versions up to 1.19.1; no fix listed
- github.com/snowflakedb/gosnowflake (Go): affected all versions up to 1.19.1; no fix listed
- github.com/snowflakedb/gosnowflake/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/snowflakedb/gosnowflake/v2 (Go): affected all versions; fixed in 2.2.0
- github.com/snowflakedb/gosnowflake/v2 (Go): affected all versions; fixed in 2.2.0
- net.snowflake:snowflake-jdbc (Maven): affected all versions; fixed in 4.3.4
- net.snowflake:snowflake-jdbc (Maven): affected all versions; fixed in 4.3.4
- net.snowflake:snowflake-jdbc-fips (Maven): affected all versions; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86597/ (Markdown: https://insights.sbomify.com/CVE-2026-86597/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86597
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86597
- OSV: https://osv.dev/vulnerability/CVE-2026-86597

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86597/
Summaries are generated and may contain mistakes; the official description above is the record.
