CVE-2026-86688 Session id is not renewed on authentication in ash_authentication, allowing session fixation
Attackers can hijack user accounts by planting session identifiers that persist after login due to missing session renewal in ash_authentication.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-86688?
CVE-2026-86688 is a high-severity authentication bypass vulnerability in team-alembic ash_authentication, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Session Fixation vulnerability in team-alembic ash_authentication allows an attacker who can plant a session identifier in a victim's browser to hold an authenticated session once that victim signs in.
AshAuthentication.Plug.Helpers.store_in_session/2 writes the authenticated subject into the existing session with Plug.Conn.put_session/3 and never calls Plug.Conn.configure_session(renew: true), so the identifier the visitor arrived with carries into their authenticated session. Every authentication event reaches this one function: the default success/4 injected by AshAuthentication.Phoenix.Controller.__using__/1, the AuthController emitted by mix ash_authentication_phoenix.install, and remember-me auto-login. AshAuthentication.Phoenix.Plug.store_in_session/2 is a defdelegate to it. Logout does not close the window either, because clear_session/2 ends with Plug.Conn.clear_session/1, which clears session contents but leaves the identifier intact, so a planted identifier survives a logout-then-login cycle.
This issue affects ash_authentication: from 0.2.0 before 4.15.0 and from 5.0.0-rc.0 before 5.0.0-rc.14.
Weakness: CWE-384
Which versions are affected by CVE-2026-86688?
1 open source package ship an affected version, including ash_authentication.
| Package | Affected | Fixed in |
|---|---|---|
ash_authentication Hex | From 0.2.0 | 4.15.0, 5.0.0-rc.14 |
How do I fix CVE-2026-86688?
Upgrade ash_authentication to a fixed version for your release line: 4.15.0 or 5.0.0-rc.14.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-86688 being exploited?
There is no known exploitation of CVE-2026-86688 in the wild and no public exploit code.
Sources
Also known as EEF-CVE-2026-86688, GHSA-v577-944g-7h3x.