CVE-2026-86731 Craft CMS 5.0.0-RC1 before 5.10.12 Permission Escalation via UsersController
Authenticated users with administrateUsers permission can activate administrator accounts, leading to privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-86731?
CVE-2026-86731 is a high-severity vulnerability in craftcms cms, published on 8 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft CMS versions 5.0.0-RC1 through 5.10.11 are missing an admin-target guard in UsersController::actionActivateUser (the users/activate-user action). While the action requires the administrateUsers permission, it does not call requireAdmin() when the targeted user is an administrator, unlike the mirror action actionDeactivateUser. As a result, an authenticated control panel user who is not an administrator but holds the administrateUsers permission can activate a pending or deliberately deactivated administrator account, which can lead to permission escalation when combined with resetting that account's password. The issue is fixed in Craft CMS 5.10.12.
Weakness: CWE-862
Which versions are affected by CVE-2026-86731?
How do I fix CVE-2026-86731?
No fix has been published for CVE-2026-86731 yet. Limit exposure of the affected software until one is available.
Is CVE-2026-86731 being exploited?
There is no known exploitation of CVE-2026-86731 in the wild and no public exploit code.
Sources
Also known as GHSA-2j7x-j7rx-9x3g, GHSA-jqf5-vfg6-8cx5.