{"answers":{"affected":"1 open source package ship an affected version, including apache-airflow-providers-apache-kafka. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-86792 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-kafka to 2.0.0 or later.","what":"CVE-2026-86792 is a high-severity code injection vulnerability in Apache Airflow Apache Kafka provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-86792 and fix it if it is affected.\n\nWhat it is: CVE-2026-86792 is a high-severity code injection vulnerability in Apache Airflow Apache Kafka provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-86792 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-kafka (PyPI): affected from 1.15.0; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86792/ (Markdown: https://insights.sbomify.com/CVE-2026-86792/index.md)","id":"CVE-2026-86792","markdown":"https://insights.sbomify.com/CVE-2026-86792/index.md","name":"CVE-2026-86792","record":{"aliases":["GHSA-8wf7-xwcv-w393","PYSEC-2026-3986"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Airflow Kafka provider","requires_auth":"low_privilege","summary":"Attackers with connection-editing privileges can execute arbitrary code on the Airflow scheduler if Kafka event producers are enabled.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-kafka","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-470","name":"Use of Externally-Controlled Input to Select Classes or Code"}],"description":"Apache Airflow Apache Kafka provider versions 1.15.0 before 2.0.0 resolve dotted-path strings found in a Kafka connection's `extra` field into Python callables via `import_string`, with no allowlist, and hand them to the confluent-kafka client which invokes them. Deployments that have enabled the Kafka event producer — `dag_run_events_enabled` or `task_instance_events_enabled`, both disabled by default — build that client inside the scheduler process, so a user whose only privilege is editing Airflow connections gains arbitrary code execution in the control plane; the Airflow security model limits connection-configuration users to code execution on workers, not the scheduler. Deployments using Google Managed Kafka are not affected, because that code path overwrites any user-supplied `oauth_cb`; plain brokers and Amazon MSK are exposed. Users are recommended to upgrade to apache-airflow-providers-apache-kafka 2.0.0 or later, which adds an allowlist configuration option for connection-string callbacks.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in Apache Airflow Apache Kafka provider","id":"CVE-2026-86792","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":3,"next":{"headline":"CVE-2026-86793","id":"CVE-2026-86793"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.0"],"introduced":["1.15.0"],"last_affected":[],"package":"apache-airflow-providers-apache-kafka","purl":"pkg:pypi/apache-airflow-providers-apache-kafka","source":"PYSEC-2026-3986"}],"prev":{"headline":"iPOSpays Payment Gateway for WooCommerce \u003c 1.4.7 - Unauthenticated Payment Confirmation Forgery","id":"CVE-2026-86791"},"products":["Apache Airflow Apache Kafka provider"],"published":"2026-09-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["Apache Software Foundation"]},"summary":"Attackers with connection-editing privileges can execute arbitrary code on the Airflow scheduler if Kafka event producers are enabled.","url":"https://insights.sbomify.com/CVE-2026-86792/"}