# CVE-2026-86792: Code injection in Apache Airflow Apache Kafka provider

> Attackers with connection-editing privileges can execute arbitrary code on the Airflow scheduler if Kafka event producers are enabled.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-8wf7-xwcv-w393, PYSEC-2026-3986

## What is CVE-2026-86792?

CVE-2026-86792 is a high-severity code injection vulnerability in Apache Airflow Apache Kafka provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow Apache Kafka provider versions 1.15.0 before 2.0.0 resolve dotted-path strings found in a Kafka connection's `extra` field into Python callables via `import_string`, with no allowlist, and hand them to the confluent-kafka client which invokes them. Deployments that have enabled the Kafka event producer — `dag_run_events_enabled` or `task_instance_events_enabled`, both disabled by default — build that client inside the scheduler process, so a user whose only privilege is editing Airflow connections gains arbitrary code execution in the control plane; the Airflow security model limits connection-configuration users to code execution on workers, not the scheduler. Deployments using Google Managed Kafka are not affected, because that code path overwrites any user-supplied `oauth_cb`; plain brokers and Amazon MSK are exposed. Users are recommended to upgrade to apache-airflow-providers-apache-kafka 2.0.0 or later, which adds an allowlist configuration option for connection-string callbacks.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2026-86792?

1 open source package ship an affected version, including apache-airflow-providers-apache-kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-kafka` | PyPI | From 1.15.0 | 2.0.0 |

Products: Apache Apache-Airflow-Providers-Apache-Kafka.

## How do I fix CVE-2026-86792?

Upgrade apache-airflow-providers-apache-kafka to 2.0.0 or later.

## Is CVE-2026-86792 being exploited?

There is no known exploitation of CVE-2026-86792 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86792 and fix it if it is affected.

What it is: CVE-2026-86792 is a high-severity code injection vulnerability in Apache Airflow Apache Kafka provider, published on 16 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86792 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-kafka (PyPI): affected from 1.15.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86792/ (Markdown: https://insights.sbomify.com/CVE-2026-86792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86792
- OSV: https://osv.dev/vulnerability/CVE-2026-86792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86792/
Summaries are generated and may contain mistakes; the official description above is the record.
