{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-86805 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-86805 is a medium-severity vulnerability in The GNU C Library glibc, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-86805 and fix it if it is affected.\n\nWhat it is: CVE-2026-86805 is a medium-severity vulnerability in The GNU C Library glibc, published on 22 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-86805 in the wild and no public exploit code.\n\nAffected product: The GNU C Library glibc. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-86805/ (Markdown: https://insights.sbomify.com/CVE-2026-86805/index.md)","id":"CVE-2026-86805","markdown":"https://insights.sbomify.com/CVE-2026-86805/index.md","name":"CVE-2026-86805","record":{"aliases":["AZL-103413","DEBIAN-CVE-2026-86805","ECHO-3f84-a5f3-00c4","GHSA-fmf4-pr35-46c2","SUSE-SU-2026:4669-1","UBUNTU-CVE-2026-86805"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"GNU C Library","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges by exploiting a race condition in glibc's dynamic loader to execute arbitrary code via attacker-controlled shared objects.","user_interaction":"required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"glibc","cpe":[],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-367","name":"Time-of-check Time-of-use (TOCTOU) Race Condition"}],"description":"A time-of-check to time-of-use (TOCTOU) race condition in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to escalate privileges. When expanding $ORIGIN in DT_RPATH for setuid/setgid (AT_SECURE) programs, glibc validates the lexically normalized search path against the trusted directories but then opens the raw, un-normalized path. On systems where the Linux fs.protected_hardlinks sysctl is disabled, a local attacker who hard-links such a program into an attacker-controlled directory and wins a race to replace an intermediate path component with a symbolic link can direct the loader outside the trusted directory, causing it to load an attacker-controlled shared object and execute arbitrary code with the elevated privileges of the program.\n\nExploitation requires an installed setuid or setgid binary whose DT_RPATH uses $ORIGIN followed by \"..\" traversal that normalizes into a trusted directory, and the ability to hard-link that binary and win the race by swapping a path component for a symbolic link. Major Linux-based OS distributions ship with fs.protected_hardlinks enabled by default and mitigate the vulnerability.","ecosystems":["SUSE:Linux Enterprise Server 11 SP4 LTSS EXTREME CORE"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AT_SECURE programs may load attacker-controlled code via $ORIGIN","id":"CVE-2026-86805","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"race_condition","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"opengeos GeoLibre _is_within_roots server-side request forgery","id":"CVE-2026-86806"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4 LTSS EXTREME CORE","fixed":["2.11.3-17.110.58.1"],"introduced":["0"],"last_affected":[],"package":"glibc","purl":"pkg:rpm/suse/glibc\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4%20LTSS%20EXTREME%20CORE","source":"SUSE-SU-2026:4669-1"}],"prev":{"headline":"seakee CPA-Manager-Plus HTTP handler.go CPAResource improper authorization","id":"CVE-2026-86804"},"products":["glibc"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-23","vendors":["The GNU C Library"]},"summary":"Local attackers can escalate privileges by exploiting a race condition in glibc's dynamic loader to execute arbitrary code via attacker-controlled shared objects.","url":"https://insights.sbomify.com/CVE-2026-86805/"}