# CVE-2026-86831: Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS

> Authenticated users can bypass NetworkPolicy enforcement on co-located pods in other namespaces by exploiting pod identifier collisions in the AWS Network Policy Agent.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Sep 2026
- **Updated:** 20 Oct 2026

## What is CVE-2026-86831?

CVE-2026-86831 is a high-severity vulnerability in AWS amazon-vpc-cni-k8s, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Improper validation of pod identifier uniqueness in aws-network-policy-agent in Amazon EKS Network Policy Agent before v1.4.0 might allow an authenticated remote user to bypass NetworkPolicy enforcement on co-located pods in other namespaces via crafted pod and namespace names that produce pod identifier collisions.

To remediate this issue, users should upgrade to Amazon EKS Network Policy Agent 1.4.0 or later and Amazon VPC CNI Managed Add-on v1.22.4 or later (which includes Network Policy Agent v1.4.0).

Weakness: CWE-1289 (Improper Validation of Unsafe Equivalence in Input)

## Which versions are affected by CVE-2026-86831?


## How do I fix CVE-2026-86831?

No fix has been published for CVE-2026-86831 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-86831 being exploited?

There is no known exploitation of CVE-2026-86831 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-86831 and fix it if it is affected.

What it is: CVE-2026-86831 is a high-severity vulnerability in AWS amazon-vpc-cni-k8s, published on 16 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-86831 in the wild and no public exploit code.

Affected product: AWS amazon-vpc-cni-k8s. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-86831/ (Markdown: https://insights.sbomify.com/CVE-2026-86831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-86831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-86831
- OSV: https://osv.dev/vulnerability/CVE-2026-86831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-86831/
Summaries are generated and may contain mistakes; the official description above is the record.
