# CVE-2026-8686: DoS from MQTT v5.0 Deserialization Fault in core MQTT

> A missing bounds check in the MQTT v5.0 property parser allows a malicious broker to cause a denial of service in applications using the coreMQTT library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-6qh9-r6jp-2wxc

## What is CVE-2026-8686?

CVE-2026-8686 is a high-severity denial of service vulnerability in FreeRTOS coreMQTT, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing bounds validation in the MQTT v5.0 property parser in coreMQTT before 5.0.1 allows an MQTT broker to cause a denial of service by sending a crafted packet.

To remediate this issue, users should upgrade to v5.0.1.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-8686?

It affects 1 product.


Products: Freertos Coremqtt.

## How do I fix CVE-2026-8686?

No fix has been published for CVE-2026-8686 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-8686 being exploited?

There is no known exploitation of CVE-2026-8686 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-8686 and fix it if it is affected.

What it is: CVE-2026-8686 is a high-severity denial of service vulnerability in FreeRTOS coreMQTT, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-8686 in the wild and no public exploit code.

Affected product: FreeRTOS coreMQTT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-8686/ (Markdown: https://insights.sbomify.com/CVE-2026-8686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-8686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-8686
- OSV: https://osv.dev/vulnerability/CVE-2026-8686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-8686/
Summaries are generated and may contain mistakes; the official description above is the record.
