# CVE-2026-87011: Open WebUI: Unauthenticated requests can stall the server via uncached OIDC fetches in back-channel logout

> Unauthenticated attackers can cause denial of service in Open WebUI by sending invalid logout tokens that trigger uncached network fetches and block the event loop.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-3g9q-v48f-hh9w, PYSEC-2026-4117

## What is CVE-2026-87011?

CVE-2026-87011 is a high-severity denial of service vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.9.0 until 0.11.1, the unauthenticated POST /oauth/backchannel-logout handler in backend/open_webui/utils/oauth.py fetched the OIDC discovery document and signing keys before validating a submitted logout token. Each request repeated uncached network fetches, and the signing-key lookup blocked the async event loop, so requests carrying invalid tokens could stall the single-worker instance and amplify traffic to the identity provider when ENABLE_OAUTH_BACKCHANNEL_LOGOUT was enabled. This issue is fixed in version 0.11.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-405 (Asymmetric Resource Consumption (Amplification))

## Which versions are affected by CVE-2026-87011?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-87011?

Upgrade open-webui to 0.11.1 or later.

## Is CVE-2026-87011 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87011 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87011 and fix it if it is affected.

What it is: CVE-2026-87011 is a high-severity denial of service vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87011 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87011/ (Markdown: https://insights.sbomify.com/CVE-2026-87011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87011
- OSV: https://osv.dev/vulnerability/CVE-2026-87011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87011/
Summaries are generated and may contain mistakes; the official description above is the record.
