# CVE-2026-87012: Open WebUI: Any authenticated user can suppress calendar alerts instance-wide via a non-numeric alert value

> An authenticated user can suppress all calendar alerts instance-wide by storing invalid data, causing a denial of service for reminders.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-v39v-59xw-j98g, PYSEC-2026-4126

## What is CVE-2026-87012?

CVE-2026-87012 is a medium-severity denial of service vulnerability in Openwebui Open Webui, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.9.0 until 0.11.1, backend/open_webui/models/calendar.py stored the calendar event meta.alert_minutes value without type validation and the shared upcoming-event scheduler compared that value numerically. An authenticated user with the calendar permission could store a non-numeric alert_minutes value that raised an exception and aborted the instance-wide alert pass, suppressing all users' reminders while the event remained in the lookahead window. This issue is fixed in version 0.11.1.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-87012?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |
| `open-webui` | PyPI | From 0.9.0 | 0.11.1 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-87012?

Upgrade open-webui to 0.11.1 or later.

## Is CVE-2026-87012 being exploited?

There is no known exploitation of CVE-2026-87012 in the wild and no public exploit code.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87012 and fix it if it is affected.

What it is: CVE-2026-87012 is a medium-severity denial of service vulnerability in Openwebui Open Webui, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-87012 in the wild and no public exploit code.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1
- open-webui (PyPI): affected from 0.9.0; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87012/ (Markdown: https://insights.sbomify.com/CVE-2026-87012/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87012
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87012
- OSV: https://osv.dev/vulnerability/CVE-2026-87012

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87012/
Summaries are generated and may contain mistakes; the official description above is the record.
