# CVE-2026-87015: Open WebUI: A user's session cookies are sent to tool servers configured for bearer authentication

> Open WebUI leaks user session cookies to external tool servers, allowing operators to hijack accounts if bearer authentication is configured.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-p78m-89r6-pgf7, PYSEC-2026-4124

## What is CVE-2026-87015?

CVE-2026-87015 is a medium-severity vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.6.27 until 0.11.1, backend/open_webui/utils/tools.py captured a cookie jar from the enclosing connection loop instead of binding it to each external tool callable. When multiple tool servers were attached and a session or system OAuth connection was processed last, a request to a different server configured for bearer authentication could include the calling user's Open WebUI session cookies, allowing that server's operator to reuse the session and take over the account. This issue is fixed in version 0.11.1.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-87015?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.6.27 | 0.11.1 |
| `open-webui` | PyPI | From 0.6.27 | 0.11.1 |
| `open-webui` | PyPI | From 0.6.27 | 0.11.1 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-87015?

Upgrade open-webui to 0.11.1 or later.

## Is CVE-2026-87015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87015 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87015 and fix it if it is affected.

What it is: CVE-2026-87015 is a medium-severity vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87015 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.6.27; fixed in 0.11.1
- open-webui (PyPI): affected from 0.6.27; fixed in 0.11.1
- open-webui (PyPI): affected from 0.6.27; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87015/ (Markdown: https://insights.sbomify.com/CVE-2026-87015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87015
- OSV: https://osv.dev/vulnerability/CVE-2026-87015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87015/
Summaries are generated and may contain mistakes; the official description above is the record.
