# CVE-2026-87016: Open WebUI: Sign-in as another user via wildcard characters in the OAuth subject claim on SQLite

> Attackers can impersonate other users, including administrators, by exploiting wildcard characters in OAuth subject claims on SQLite deployments.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 14 Sep 2026
- **Also known as:** GHSA-wpmr-8h3q-fwj7, PYSEC-2026-4128

## What is CVE-2026-87016?

CVE-2026-87016 is a high-severity authentication bypass vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Open WebUI is an extensible, feature-rich, and user-friendly self-hosted AI platform. From 0.6.41 until 0.11.1, get_user_by_oauth_sub and get_user_by_scim_external_id in backend/open_webui/models/users.py used JSON contains matching that compiled to SQL LIKE substring matching on SQLite. An OAuth subject containing percent or underscore wildcard characters could resolve to a different stored identity, potentially selecting an administrator account and issuing the attacker that account's session; PostgreSQL deployments were not affected. This issue is fixed in version 0.11.1.

Weakness: CWE-287 (Improper Authentication), CWE-155 (Improper Neutralization of Wildcards or Matching Symbols)

## Which versions are affected by CVE-2026-87016?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | From 0.6.41 | 0.11.1 |
| `open-webui` | PyPI | From 0.6.41 | 0.11.1 |
| `open-webui` | PyPI | From 0.6.41 | 0.11.1 |

Products: Openwebui Open Webui.

## How do I fix CVE-2026-87016?

Upgrade open-webui to 0.11.1 or later.

## Is CVE-2026-87016 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87016 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87016 and fix it if it is affected.

What it is: CVE-2026-87016 is a high-severity authentication bypass vulnerability in Openwebui Open Webui, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-87016 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected from 0.6.41; fixed in 0.11.1
- open-webui (PyPI): affected from 0.6.41; fixed in 0.11.1
- open-webui (PyPI): affected from 0.6.41; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87016/ (Markdown: https://insights.sbomify.com/CVE-2026-87016/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87016
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87016
- OSV: https://osv.dev/vulnerability/CVE-2026-87016

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87016/
Summaries are generated and may contain mistakes; the official description above is the record.
