{"answers":{"affected":"6 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-87018 in the wild and no public exploit code.","fix":"Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.","what":"CVE-2026-87018 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-87018 and fix it if it is affected.\n\nWhat it is: CVE-2026-87018 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-87018 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- undici (npm): affected from 4.2.1; fixed in 6.29.1\n- undici (npm): affected from 4.2.1; fixed in 6.29.1\n- undici (npm): affected from 7.0.0; fixed in 7.30.1\n- undici (npm): affected from 7.0.0; fixed in 7.30.1\n- undici (npm): affected from 8.0.0; fixed in 8.12.2\n- undici (npm): affected from 8.0.0; fixed in 8.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-87018/ (Markdown: https://insights.sbomify.com/CVE-2026-87018/index.md)","id":"CVE-2026-87018","markdown":"https://insights.sbomify.com/CVE-2026-87018/index.md","name":"CVE-2026-87018","record":{"aliases":["CLEANSTART-2026-OM39297","DEBIAN-CVE-2026-87018","ECHO-9235-5684-d417","GHSA-qrxm-fqhp-jwvm","ROOT-APP-NPM-CVE-2026-87018","UBUNTU-CVE-2026-87018"],"analysis":null,"analysis_generated_by":null,"assigner":"openjs","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-617","name":"Reachable Assertion"},{"id":"CWE-248","name":"Uncaught Exception"}],"description":"undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":null,"year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Tanium addressed an improper access controls vulnerability in Comply.","id":"CVE-2026-87019"},"packages":[{"ecosystem":"npm","fixed":["6.29.1"],"introduced":["4.2.1"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-qrxm-fqhp-jwvm"},{"ecosystem":"npm","fixed":["6.29.1"],"introduced":["4.2.1"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-qrxm-fqhp-jwvm"},{"ecosystem":"npm","fixed":["7.30.1"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-qrxm-fqhp-jwvm"},{"ecosystem":"npm","fixed":["7.30.1"],"introduced":["7.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-qrxm-fqhp-jwvm"},{"ecosystem":"npm","fixed":["8.12.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-qrxm-fqhp-jwvm"},{"ecosystem":"npm","fixed":["8.12.2"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-qrxm-fqhp-jwvm"}],"prev":{"headline":"Open WebUI: Inaccessible knowledge bases are exposed through the built-in knowledge tool on most vector backends","id":"CVE-2026-87017"},"products":["undici"],"published":"2026-10-15","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-16","vendors":["undici"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-87018/"}