# CVE-2026-87018: undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** CLEANSTART-2026-OM39297, DEBIAN-CVE-2026-87018, ECHO-9235-5684-d417, GHSA-qrxm-fqhp-jwvm, ROOT-APP-NPM-CVE-2026-87018, UBUNTU-CVE-2026-87018

## What is CVE-2026-87018?

CVE-2026-87018 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. 

### Official description

undici is an HTTP client library for Node.js. In versions 4.2.1 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, the client process crashes when a TLS 1.2 server renegotiates after the connection is established and presents a different, CA-trusted certificate whose hostname does not match the requested host. Node.js re-runs hostname verification on the renegotiated handshake and destroys the socket with a certificate-altname error, but undici's established-socket error handler asserted that this error code could never occur, so the peer-controlled error became an uncaught assertion that terminates the Node.js process, affecting both the HTTP/1.1 and HTTP/2 paths. A malicious or compromised HTTPS endpoint reached through undici or the global fetch() can crash the client with a single server-initiated renegotiation, taking down all in-flight requests and background work in the process, and exploitation needs no CA compromise because the attacker controls the endpoint and can present two ordinary valid certificates. Only TLS 1.2 is affected, since TLS 1.3 does not support renegotiation. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, and users should upgrade to one of those versions or later. As a workaround, restrict outbound connections to TLS 1.3 so renegotiation cannot occur, when the target endpoints support it.

Weakness: CWE-617 (Reachable Assertion), CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-87018?

6 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 4.2.1 | 6.29.1 |
| `undici` | npm | From 4.2.1 | 6.29.1 |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 7.0.0 | 7.30.1 |
| `undici` | npm | From 8.0.0 | 8.12.2 |
| `undici` | npm | From 8.0.0 | 8.12.2 |

Products: Nodejs Undici.

## How do I fix CVE-2026-87018?

Upgrade undici to a fixed version for your release line: 6.29.1, 7.30.1 or 8.12.2.

## Is CVE-2026-87018 being exploited?

There is no known exploitation of CVE-2026-87018 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)
- [CVE-2026-6734](https://insights.sbomify.com/CVE-2026-6734/): undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-87018 and fix it if it is affected.

What it is: CVE-2026-87018 is a high-severity vulnerability in Nodejs Undici, published on 15 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-87018 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 4.2.1; fixed in 6.29.1
- undici (npm): affected from 4.2.1; fixed in 6.29.1
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 7.0.0; fixed in 7.30.1
- undici (npm): affected from 8.0.0; fixed in 8.12.2
- undici (npm): affected from 8.0.0; fixed in 8.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-87018/ (Markdown: https://insights.sbomify.com/CVE-2026-87018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-87018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-87018
- OSV: https://osv.dev/vulnerability/CVE-2026-87018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-87018/
Summaries are generated and may contain mistakes; the official description above is the record.
